Please login or register.

Login with username, password and session length
Advanced search  

News:

Planet Explorers Released!

Author Topic: iso guns [marked]  (Read 325 times)

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
iso guns [marked]
« on: February 15, 2017, 08:47:37 PM »

I'm not sure what triggers, it may just be a certain amount of time playing without fast travel/exiting the game, this but after some time iso guns, maybe all weapon isos but I've only got custom guns, some get corrupted. No amount of weapon swapping, running around etc. but if I fast travel or quit to the main menu.

I'm using a intel i5-7600K, 32GB ram. Currently I'm using the IGP as my display doesn't work with my new graphics card.

Here are before & after fast travel pictures - http://imgur.com/a/jhjU0

The iso for the particular gun is attached
« Last Edit: February 16, 2017, 03:16:22 AM by Dorist1 »
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2190
    • View Profile
Re: iso guns [marked]
« Reply #1 on: February 16, 2017, 03:17:33 AM »

This image is not clear about the corruption. Could you make it clear how it influence the game play?
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #2 on: February 16, 2017, 08:14:32 AM »

There's no game play issue it's just the rendering of the guns.
Logged

Luminaire

  • Global Moderator
  • Citizen
  • *****
  • Karma: 35
  • Posts: 469
  • Dream Deity
    • View Profile
Re: iso guns [marked]
« Reply #3 on: February 16, 2017, 12:26:57 PM »

I'm having a difficult time figuring out what's being shown in these images aswell.. You mentioned rendering, but i'm still unable to see it... Could you explain it a bit more in detail?
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #4 on: February 17, 2017, 09:24:37 AM »

If you look at gun in the picture aiming into the sky you can see that it looks like a bunch of blobs with almost no flat surfaces and no defined lines. Compare that to the gun in the forest you can see the flat surfaces. It's like the blocks become misaligned when rendering.
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2190
    • View Profile
Re: iso guns [marked]
« Reply #5 on: February 20, 2017, 03:43:26 AM »

Did you minimize the game and reopen it again?
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #6 on: February 20, 2017, 03:23:38 PM »

No, I was hunting and noticed that my iso gun was all 'funky' looking I swapped to that one & it was definitely wrong messed about a lot but to no avail.

Loaded my build save game and all okay.

Went back to my original game and still okay. Then some hours latter the same thing happened, but ignored it and carried on playing as it didn't effect the game play only the rendering. Eventually I fast traveled & it went away. I've noticed this behaviour several times now.

You can get a very similar effect in certain light conditions where the light has a low angle of attack on some surfaced and puts other surfaces in deep shadow, but this doesn't change the shape of the gun. 
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2190
    • View Profile
Re: iso guns [marked]
« Reply #7 on: February 21, 2017, 02:40:28 AM »

I see. This is caused by different light circumstances. The ISO is not changed. It's just the look of it.
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #8 on: February 23, 2017, 09:45:01 PM »

No this issue isn't but the effect is very similar to the effect caused by a lighting condition. The difference is when it's a lighting effect, a relatively small movement will result in the gun being seen correctly. However, what I'm seeing is lighting condition independent.

I've noticed that it happens when I approach my base very quickly (e.g. via the monorail). When I get near/into the static shield the frame rate drops to single figures and the player character is trapped for about 5 seconds until all the NPCs, turrets, etc are drawn. If I run/walk to the base it's fine. Could this be a side effect of the IGP not being able to keep up?
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #9 on: March 04, 2017, 08:32:54 AM »

Having the corruption issue again, fast travelled to the assembly core & the result was texture oddities. See here. I've not been able to reproduce the texture issue reliably but this is my first gun which relies totally on textures for colouring. The iso can be downloaded from here
Logged

Iron Newt

  • Enlistee
  • *
  • Karma: 0
  • Posts: 39
    • View Profile
Re: iso guns [marked]
« Reply #10 on: March 18, 2017, 12:56:32 PM »

Update: these issues appear to be cause by the intel HD6#0 graphics driver. They're not present when playing on an Iris 6100 IGP or NVidia GTX 1060
Logged