Pathea Games Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Planet Explorers Released!

Author Topic: Lumi's Adventures. Journal of the rights and wrongs.[marked]  (Read 571 times)

Luminaire

  • Global Moderator
  • Citizen
  • *****
  • Karma: 36
  • Posts: 485
  • Dream Deity
    • View Profile
Lumi's Adventures. Journal of the rights and wrongs.[marked]
« on: January 13, 2017, 11:46:26 AM »

Now that PE is nearing it's full bloom, I would like to take some time to truely overview the full experience of the Planet Explorers gameplay. This will only cover adventure mode, but it is mostly to make note of anything from bugs in mechanics, to even little things like minor inconveniences and nuisances. I thought I'd give my full rundown on how I feel about the experience, and hopefully insight some correction of some small annoyances that make the experience daunting for people. Whether it is a gamebreaking bug, or me simply stubbing my toe on the assembly core every time i try to run through my colony, I'll document as I go along. I do realize that it's possible that much of this may not be able to be corrected, or that, again, some of it may not be important enough to adjust, but I will document them regardless.

Picture perfect: Character and world Creation
To set the stage, I have begun an entirely new adventure game. I've started in the character creation screen, and have created my character. Rather than being decent though, I am standing in the editor in my underwear. What does someone have to do to get some clothes around here?

It would be nice to have some form of clothing in the creator, with a tickbox for hiding them to help with the modelling. But previews are a very nice thing to have. You can sometimes look a little different wearing outfits than you'd imagine, so unless you plan to run around the game in your underwear, it would be convenient to have some clothe previews. Maybe a few options to check through, or maybe even a few choices of starting clothing, rather than the default black outfit? Just a thought.. (I would also love to see some form of clothing options for the character selection on multiplayer. The naked characters standing there just feels somewhat unfinished and not cared enough for)

I have started my world with the settings below:

Skill Tree active.

Platform Towns
After starting my world, I entered the game in a small town a bit uplifted from the ground level... a bit.. The music is wonderful, and the atmosphere has this otherworldly feel to it. I love this biome..
But this town.. The first oddity that strikes me.


In PE, all towns are raised on these strange platforms. You can't seem to find a town that's gently nestled into the ground as if all people did was clear out a nice spot and start setting up buildings and settling in, like you'd expect. They are raised quite readily above the ground and in most cases are a downright pain just to get into, requiring you to circle the town until you find the large ramp, or exploit wall jumping until you reach the top.. This one, is in the middle of the water.

I am also quickly noticing that this is a lot of water.. So I am hoping that I did not receive less land then I was hoping for, but we'll make do with what we're given, and see where this goes.

Buildmode key inconvenience
After taking this screenshot above from Free look mode, i pressed the B button again to exit build mode and continue on my way. But much to my unexpectation, it didn't exit build mode. I'm required to first exit free look, by pressing F again, and -then- press B again to exit buildmode. Perhaps B should exit buildmode immidiately from free look. I can imagine this might be a problem if i'm building my temple and i come under attack.

***
Mission Location placement
I have accepted the first couple of missions from the townspeople. I was given the starting scripts which range from most all the essentials I can think of. I wasn't given a food script, but atleast the merchant here is selling food, so that shouldn't be too much of an issue. But..


This might be.. This individual has asked me to hunt in the middle of a swampy ocean, but first I need to place turrets.. under water? Can I even do that? We're about to find out.
Yes, yes I can.



***
Swimming Camera
Swimming through this water, i noticed something a bit discomfortable, and that is that it was difficult to keep myself both on the surface, and the camera not under water. Since the direction you swim seems to be based off your camera (atleast in my current controls, maybe? My curser is unlocked), if I had my camera above water, my character would swim down. If i tried to correct their angle, my camera would end up under water. It took a little working, but through some camera placing along with the spacebar button, i did manage to level it to a point I could swim across the water surface without issue.

***
Inconsistent plant harvesting box
This is a rather weird one... I have begun harvesting plants, and i've noticed that the icon appearing over the plant to harvest seems very iffy. Sometimes, it appears quite easily, and remains for a large coverage area of me moving around the mouse. no problem there. But if I change direction/position of my character, or even JUSt the camera angle, the same plant may become unclickable, even though the distance I am from it has not increased/decreased. The way I am facing does not seem to be the deciding factor either. The harvesting icon sometimes appears while i'm facing away from the plant, and sometimes is not there while i'm facing it. Distance from the plant, again, doesn't seem to have any impact on whether or not the curser picks it up.
I have experimented a little with trying to get this pick up icon to appear on the same plant. For the most part, it seems there, but it's very inconsistent, and sometimes there is absolutely nowhere I can place my curser for the pick up icon to appear. It is as if the plant is not even there. Camera location or character position/location, or both. Something that shouldn't is interfereing with the ability to get that curser to appear.

***
My first dungeon, totally not prepared! (but that's ok)
I began my first journey, setting out, away from the town I spawned in. Luckily, there is indeed land in this world. How much, I'm not quite sure yet, but atleast enough for me to enjoy the scenery, and that, I certainly did.

There was even a solo bird that fluttered high in the sky in the distance, across the road, adding to the marvel, a little ways past this. Unfortunately I did not get a screenshot of this..
Along my travel though, I noticed a dungeon off to the side, barely still on land, next to the water. I approached to see what level it was, and much to my glee, it was a level 2. One of those rocky cave dungeons.
I entered the dungeon, well knowing that I couldn't really fight my way through, but I had to see how efficient i could be with my little wooden sword and shield. The enemies unfortunately were a bit too strong, in that i did not manage to lower their hp bars by much before one of them smacked me, reducing my hp to roughly 40%. Owch. Also, my footsteps sound like i'm running on stage props.
Instead of fighting, I decided to run through and grab whatever loot I could. I didn't get a whole lot, but at the end, after looting the final container, I ended up with cortical shoes, and a few bedroom pieces. Not bad for doing nothing. But then ah, how do I exit? This wall infront of me doesn't seem to be working... Oh.. I need to travel up that side rock that looks like a piece of the surrounding wall, leading to what doesn't really look like much of an exit either >.< (No, i didn't manage to cheap an ISO this time)

***
Toe stubs: Sticky terrain collision
Ah, a dreaded issue i've hated for so long, and was sure It would not be long before I would experience, and not long indeed.
I started my first mining expedition against a mountain side, to start off my building material collection with stone and marble. I dug a small  wide hole, that was very short. Only a few feet deep, and went to jump out of it when i wanted to move on. (I didn't mine a whole lot.)
But as I did, i ran up to the edge of the hole, and attempted to jump onto the upper ledge. Instead, i played the animation to jump, and moved about a couple inches upwards before colliding into the terrain with my knee, which stopped me in my tracks completely. Further attempts to jump yielded no results. I had to back up, and attempt the jump again, away from the terrain.


.. Why can do this?


Collisions in PE are just too sticky.. I understand that people do not want to slide on staircases, and slight hillsides while they are trying to cut trees, but surely you can find some sort of medium ground to make this work better. It is a wide issue, not just with terrain, but objects in general too. Running through your colony, you run into corners of your blocks, or edges of machines. The colony assembly core is a nightmare. Trees, plants, and even wildlife have a very strong sticky collision feel to them that is really breaking and unsmooth. It is a very uncomfortable feel.

***
I've come to my next town, and after defeating the secret hideout mischief makers, I'll need to pause my journey here for the time being. But I would like to close for now by saying that PE does seem to have a lot of little potential quality of life adjustments, that I think if polished up a little, would improve player comfort with PE. There are bits here and there that make the game feel a little clunky, aswell as minor inconveniences that tend to add up quickly. I only spent about 3 hours writing this up as I was playing, and did not honestly do a whole lot, but all the above are little things that I ran into in that time. It feels like every activity I participated in, there was at least something that didn't go smoothly.

I adore you developers, and recognize how difficult it's been. Even if PE doesn't become a perfectly smooth gameplay experience, I'm hoping that with your future projects, you can take quite a bit with you from all this, and do even better. Definitely think about some of these things for PE2. Not just features, but the little things as well.

To be continued..
« Last Edit: January 16, 2017, 02:22:12 AM by Dorist1 »
Logged

Luminaire

  • Global Moderator
  • Citizen
  • *****
  • Karma: 36
  • Posts: 485
  • Dream Deity
    • View Profile
Re: Lumi's Adventures. Journal of the rights and wrongs.[marked]
« Reply #1 on: January 16, 2017, 07:49:13 PM »

Episode Two: The grenade that saved the village.

Biome Appropriate Missions
After loading up my game to continue my adventure, I realized I had made a mistake, and had not yet picked up any followers. I ran around the current town I was in looking for anyone willing and could not find anyone, so I fast-traveled back to the first town to complete some of the missions that i was given.

There it was that I realized the reason I had not completed those missions was because they required materials gathered from other biomes. This wasn't too much of an issue, as I had noted before that there was a seller who sold food along with plants. I sook out this seller and purchased the necessary plants to complete the mission, due to being in the Swamp biome, and those plants only being available in grassland and forest.

I turned these missions in, and was given a second mission from one of them, which is fine, except... oh dear...


Another mission that required me to hunt enemies located in the grasslands.
Luckily, I was still able to complete this mission due to the convenient spawning of enemies right at the base of the town upon accepting the mission.
(I don't believe these should spawn when missions are accepted. If enemies are meant to spawn in certain biomes, which they do, it should require the player to go hunting a bit. The mission seems a little pointless if the objectives are dropped ontop of the players head when they accept them.)
If missions could be appropriate to the biomes they were accepted in, it might also breath a little bit more life into them being present and meaningful.

Ammunition passing through enemies
After picking up two followers and continuing on my adventure, I came across a big mean crocadile that wanted to eat me and my new companions. I pulled out my handy dandy little wooden bow and strafed it's attacks while firing at it. One thing I noticed, was that if i was within melee range of the enemy, and fired a shot, the shot would pass through the enemy completely, doing no damage. I tried to get a screenshot of this, but my attempts failed, as i couldn't cordinate my timing of hitting the screenshot button with with my mouseclicks and strafing at the same time. ..

No resources at the time of death.
Title not very descriptive, I had run out of arrows fighting off crocodiles, so I went to chop down a tree to get more wood in order to craft more arrows. The moment I swung my axe for the final hit on the tree, so too did a croc on my head, and down both me and the tree went. Unfortunately, all that wood disappeared into the void, as the tree fell, but i was not given any wood from it. I once again, attempted to get a screenshot of my dying, along with the tree falling, but I missed the shot by a few seconds it seems.. I'm being very slow today :c

Paper thin Security
Now I understand why all towns are built on platforms. Because the colony security is so thin and lightweight, that any common beasty running into town would mess them up on an hourly basis. The town guards and general protection are lacking. Extremely lacking.
I think there should be a bit more armed protection than there is, considering how dangerous this world is.

These two crocodiles had a heck of a joyride, running around this town knocking down colonists, armorers and weaponsmiths who were zerging them with colony clothing, leather armor, and survivalist knifes. For twenty minutes all the citizens ate the dust (and drank swamp water), then got back up just to be knocked down again, slowly wittling away the two assailants hp before I ended the parade with a grenade. (to be fair, they killed one, and got the other one down to a decimal percentage of it's life left. It just seemed the right thing to do, as i had no more bullets, nor arrows)
My suggestion would be to better equip armorers and weaponsmiths, since they aren't able to be recruited and taken advant- er, share their equipment, aswell as have some unrecruitables be better geared to defend the town. Without the immortality that has somehow been procured on this world, I don't know how they would survive.

As for my own followers, I have opted to dismiss them for the time being. I have run out of revival shots, and do not have the resources at this moment to continue buying them. I'll return for them after building up a bit of supplies around this town before continuing to my designated waypoint for "Delayed Supplies".
Logged

yarnevk

  • Andhera Rider
  • Planetary Hero
  • ******
  • Karma: 51
  • Posts: 2297
    • View Profile
Re: Lumi's Adventures. Journal of the rights and wrongs.[marked]
« Reply #2 on: January 23, 2017, 11:20:07 PM »

Having come back to it with new user eyes myself as if it was a new game, I agree with much of the new user experience lacking.  Likewise I am only doing adventure mode since the bug reports makes it clear that story mode still needs much work.  The downward trend in steam reviews seems to agree, but then you will always have that at release of people buying a niche game when they do not fit into that playstyle niche.  They are in the catch22 of releasing too early to get more money only to find bad steam reviews driving off more money that they need to polish the game.   Sadly it is even worse than it should be because No Mans Sky has tainted this category, so releases of similar themed games need to be stellar.  Pricewise if you stick to even just uncovering the map it is a good deal, but how many will make it that far in because of the lack of polish, or make it past that and deep into building and creating where the game has no peers?

Some comments on your comments, but in general maybe this game is destined to be like Elder Scrolls and it will be fan modding that polishes it up, not me though I gave up on it years ago.

Towns are elevated as defensive forts, dirt is cheaper than soldiers.  Lot easier to shoot down at mobs that cannot find their way up the ramp, and keeps the idiot stags from grazing thru your town.  Also makes it easier to see the town across the horizon for the lost explorers.

This is a change from alpha where towns was cut into the landscape with more futuristic architecture that needed better equipped military support to the point they did not really need you hanging around.   Now it has more of pioneer architecture of fewer people just trying to survive that could use your help, I like it better this way even though they stuck with the settlers story rather than lone survivor experience.   Leave them to be eaten by crocs, or leave them with some turrets, it makes you the special guy either way.

Going deeper into the map I get spanked by much better Marian security.  I think it reinforces the story that we humans are not the best even though we think we are.

The biggest annoyance is finding a town then them refusing mission requests because you already have one from your old town that was too high level to complete.  I could delete the mission, but then I lose it for the future.  Let me accept multiple missions in my log, but then when I am ready the follower can meet me at it's spawn point (the way Skyrim handles follower missions)

Plant picking is interfered with if you have your weapon out.  Would make more sense if it swapped to your knife to pick rather than being an idiot.  Otherwise the pick icon seems to solve the maddening standing in the plant and not being able to pick it, if I have the icon it picks, seems I do not even need my knife anymore.

It took a while to find food seller with the food scripts, while the vegetarian diet from the flora is adequate in the early game, it just did not seem to make sense they would not hand out the basic meat scripts with the wood weapons, so early game you sell meat to buy food or eat veggie?  The game is really lacking that early campfire survival feel of roast dino on a stick that it needs, and by the time you find the town that sells the meat on the stick script, you are well past needing it anymore.  The starter adventure scripts should be the same wood and meat scripts that the early Gerdy tutorial in story mode had, the entire point is that your personal replicator is preprogrammed only for survival, but you cannot even do that in the proper caveman way!

When did caves fall out of alpha, I find the dungeons a poor metagaming random spawn MMO drops substitute for them.  Caves was scary because they felt real and part of the world.   No Mans Sky had OK cave generation with horrible shoot to mine mechanic, but I think the alpha PE caves was much better as it was way more fun finding mining seams in open caves and having to actually mine them out.  But that was back before the scanner when you actually had to explore to find seams.

A procedural dungeon is cool in a dungeon crawler game where that is the purpose, here it seems oddly out of place, they are not even integrated into the environment just random surface spawns that dissapear when finished!  Why are all these things in the dungeon and why are they fighting me?  Why does the game tell me the level at the door rather than just spanking me because I wandered into a bad area like the open world outside does?   The same dungeon idea would have worked much better by infesting caves with mobs and treasure, more than just bugs it would make sense that the baddies you want to fit would have found their way into the underworld.  As it is now it suffers from procedural sameness, something you need to grind just to get the drops because the stores are lacking.   
 
Mission spawning on your head is just dumb design. Even in fort defense seeing the herd coming is more fun than getting wacked on the head.   In the open world it completely removes any other option but wack a mole combat, no stealth or ranged is even possible.  If people wanted instant spawn combat for funsies, that is what the monster spawner device is for.  Half of these head drop missions completed for me without my participation because the town was killing stuff while I was browsing. I did not even realize the mission was on until it was over.   I see why they did it though, because there was so many complaints about the walk to here missions never triggering, but I think it could have resolved it better just by doing the head drop only if you have walked far enough away from base that the entire town is not joining in.

The NPC immortality was weird when I ran across my follower that I had left for dead, but then it is sci-fi if you can revive or wakeup in town so can they!  (Main story having a burial plot makes no sense then)  I like the Skyrim method of inconsequentials can die, only story NPC has to stay alive.  Lack of death just makes people get sloppy in their strategy and takes away the risk from exploration. 

Footsteps needs to have it's own fader, the mix is way too high for them compared to the rest of the sound effects.  First person view is down at chest level rather than eye level.  My lvl3 jeep ISO drop was fun while it lasted, but the poor road construction of the colonists ended that joy ride early for me. But these are the types of easy to fix things that one would expect for post release polish that got missed, rather than some inherent issues that will take years to still fix.
« Last Edit: January 24, 2017, 12:31:02 AM by yarnevk »
Logged