Pathea Games Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Planet Explorers Released!

Pages: [1] 2

Author Topic: Dedicated server "Severe server error" (Debian Jessie 64)[marked]  (Read 1256 times)

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile

Hello everybody,

First, sorry for my english, i'm swiss ;)

I'm trying to set up a dedicated server on Debian jessie 64. but i can't get it to work.
The connection fails instantly after i entered the password with this message:
 "Severe server error, unable to continue. Please create a new server, if this issue persists, please report this bug to the developers".

(I've already set up a server running fine on my computer on win7, but i have a rented dedicated gaming server at soyoustart running debian jessie 64, so i'would like to use it for my server)


I will list the process i've done: (I replaced some path infos with XXX)

1. Installed the server from steamcmd (.......app_update 237870 validate.....)
2. Modifyed the ServerConfig.conf file here "/XXX/XXX/PE/HeadlessServer/ConfigFiles"
Here is the file contents:
Code: [Select]
{
        "LobbyIP" : "74.81.173.196",
        "LobbyPort" : 12534,
        "ProxyIP"   : "119.28.5.150",
        "ProxyPort" : 12535,
        "TeamNum"   : 2,
        "NumPerTeam" : 2,
        "GameMode"   : 1,
        "GameType"   : 2,
        "MonsterYes" : true,
        "ServerName" : "KosExploWorld1",
        "MapName"    : "",
        "MapSeed"    : "KosMapSeed",
        "TerrainType" : 1,
        "ClimateType" : 1,
        "VegetationType" : 1,
        "MasterRoleName" : "Narkos",
        "Password"       : "XXX",
        "PublicServer"   : true,
        "Proxy"          : false,
        "UseSkillTree"   : true,
        "DropDeadPercent" : 0,
        "UnlimitedRes"    : false,
        "TerrainHeight"   : 512,
        "MapSize"         : 2,
        "RiverDensity"    : 10,
        "RiverWidth"      : 10,
        "PlainHeight"     : 20,
        "Flatness"        : 50,
        "BridgeMaxHeight" : 100,
        "AICount"         : 3,
        "ScriptsAvailable" : true
}
3. Forwarded the ports UDP 9900 to 9915 (Also tryed with allowing any UPD connections port)
4. I start the server with this commande line:   sh PEStart.sh
It runs this file:
Code: [Select]
#! /bin/bash
/XXX/XXX/PE/HeadlessServer/PE_Server.x86_64 -nographics

The server start fine and is listed in the ingame server list.
But can't connect to it, I always get this message "Severe server error, unable to continue. Please create a new server, if this issue persists, please report this bug to the developers".

Please can someone help me a bit?
Thank you in advance

********************************************************
EDIT to add the last logs files:

file: 3_1_2017_exception.log
Code: [Select]
[Exception]:03/01/2017 15:06:07
FormatException: Unknown char: .
System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider)
System.Single.Parse (System.String s)
System.Convert.ToSingle (System.String value)
AiUtil.ToVector3 (System.String vecString)
AISpawnPoint.LoadData ()
LoadManager.Load ()
uLinkNetwork.uLink_OnServerInitialized ()
UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
#=qzBVPlhHqyune7KfGFdCI6QEUnP0fs1fLWPewHpWItjk=:#=qD5NIjY69Tg$BLsv4qq5MLw==(String, Object)
#=q0zCihwcKnSIMPGpHF0aOTD42bVeGyg6zm2_bNKijhVA=:#=q1ps8gOmgOjy5R1NzpG9zqw==(String, Object)
#=qBsHAklsGYCH8wkaeOQonABxqVuDbW791Ilucxb$6Rgs=:#=qKZaiYVJQietXxTYb6qy5K_toUVerSnDvV8c0YJ$GoQA=(Int32, Int32, Int32)
#=qBsHAklsGYCH8wkaeOQonABxqVuDbW791Ilucxb$6Rgs=:#=q89hRx8A2wwLko1w2EjvTgU7uZC4ga1P1OowMOEsieUo=(Int32, Int32, Boolean)
uLink.Network:InitializeServer(Int32, Int32, Boolean)
NetInterface:InitializeServer(Int32, Int32, Boolean)
uLinkNetwork:Start()

file 3_1_2017_log.log
Code: [Select]
[Log]:03/01/2017 15:06:07
Current server version:261

[Log]:03/01/2017 15:06:07
Server initialized on port:9900

file 3_1_2017_warning.log
Code: [Select]
[Warning]:03/01/2017 15:18:52
Socket ReceiveBuffer is actually set to 425984 and not the desired 134217728

[Warning]:03/01/2017 15:18:52
Socket SendBuffer is actually set to 425984 and not the desired 134217728

Server console log:
Code: [Select]
Found path: /XXX/XXX/PE/HeadlessServer/PE_Server.x86_64
Mono path[0] = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Managed'
Mono path[1] = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Mono'
Mono config path = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Mono/etc'
« Last Edit: January 04, 2017, 02:36:41 AM by Dorist1 »
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #1 on: January 04, 2017, 03:21:23 AM »

The log shows that your save has broken. You can try opening a fresh one on the server to see whether it works. We only tested the server on Linux Ubuntu, so it's not sure whether it'll work on debian or not.
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #2 on: January 04, 2017, 01:05:03 PM »

Hello Dorist1,

Thank you for your reply, but sorry it does not help me.

I installed, tested, uninstalled and then reinstalled the server several times.
I launched at least 15 games with different names, deleting each time the world repertoire.

I tried with several different configurations to check if this was not one of the configuration options that caused the server to crash (eg mapsize too big, gametype and gamemode etc)

You said "We only tested the server on Linux Ubuntu, so it's not sure whether it'll work on debian or not".
Can somebody make a test on Debian (Jessie or newer)? (This is to know if the problem come from my server, or the OS type)

Thank you in advance for your answer.

« Last Edit: January 04, 2017, 01:07:08 PM by Narkos »
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #3 on: January 09, 2017, 05:33:12 PM »

Hello,

I'm sorry Dorist, I'm not sure to understand, this was your only answer? My problem will end like that?
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #4 on: January 11, 2017, 02:37:41 AM »

We're currently having test on this, but it needs time to figure this out.
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #5 on: January 11, 2017, 06:41:29 PM »

Hello Dorist1,

Thank you very much for that answer, it's great to hear that.
I runned a lot of game servers like conterstrike, trackmania, COD, minecraft, ark survival, 7daystodie,.. and I would be very happy if I could help you out in some way.
So tell me if i can test or do something usefull ....
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #6 on: January 12, 2017, 02:17:44 AM »

We can run it on debian properly, could you share your config file and let us have a look?
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #7 on: January 12, 2017, 06:53:09 PM »

Hello Dorist1,

Thank you for your answer.

I deleted all the files again, and did a fresh install via steamcmd.
Here is the config file I used:
Code: [Select]
{
        "LobbyIP" : "74.81.173.196",
        "LobbyPort" : 12534,
        "ProxyIP"   : "119.28.5.150",
        "ProxyPort" : 12535,
        "TeamNum"   : 2,
        "NumPerTeam" : 16,
        "GameMode"   : 1,
        "GameType"   : 1,
        "MonsterYes" : true,
        "ServerName" : "KosFreshTest",
        "MapName"    : "",
        "MapSeed"    : "patheamaria",
        "TerrainType" : 1,
        "ClimateType" : 1,
        "VegetationType" : 1,
        "MasterRoleName" : "Unknown",
        "Password"       : "",
        "PublicServer"   : true,
        "Proxy"          : false,
        "UseSkillTree"   : false,
        "DropDeadPercent" : 10,
        "UnlimitedRes"    : false,
        "TerrainHeight"   : 512,
        "MapSize"         : 2,
        "RiverDensity"    : 1,
        "RiverWidth"      : 1,
        "PlainHeight"     : 20,
        "Flatness"        : 25,
        "BridgeMaxHeight" : 100,
        "AICount"         : 3,
        "ScriptsAvailable" : true
}

I only modified this 2 lines from the original config file:
Code: [Select]
"ServerName" : "PlanetExplorer",               TO               "ServerName" : "KosFreshTest",
"PublicServer"   : false,               TO               "PublicServer"   : true,

First line to indicate a server name to be able to find it in the server list
Second line to make it visible in the server list

And it still do not work.
When I try to join the server I always get the same message "Severe server error, unable to continue. Please create a new server, if this issue persists, please report this bug to the developers".

So I don't understand what  I do wrong...

There are the logs:
file: 12_1_2017_exception.log
Code: [Select]
[Exception]:12/01/2017 20:08:57
FormatException: Unknown char: .
System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider)
System.Single.Parse (System.String s)
System.Convert.ToSingle (System.String value)
AiUtil.ToVector3 (System.String vecString)
AISpawnPoint.LoadData ()
LoadManager.Load ()
uLinkNetwork.uLink_OnServerInitialized ()
UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)
#=qzBVPlhHqyune7KfGFdCI6QEUnP0fs1fLWPewHpWItjk=:#=qD5NIjY69Tg$BLsv4qq5MLw==(String, Object)
#=q0zCihwcKnSIMPGpHF0aOTD42bVeGyg6zm2_bNKijhVA=:#=q1ps8gOmgOjy5R1NzpG9zqw==(String, Object)
#=qBsHAklsGYCH8wkaeOQonABxqVuDbW791Ilucxb$6Rgs=:#=qKZaiYVJQietXxTYb6qy5K_toUVerSnDvV8c0YJ$GoQA=(Int32, Int32, Int32)
#=qBsHAklsGYCH8wkaeOQonABxqVuDbW791Ilucxb$6Rgs=:#=q89hRx8A2wwLko1w2EjvTgU7uZC4ga1P1OowMOEsieUo=(Int32, Int32, Boolean)
uLink.Network:InitializeServer(Int32, Int32, Boolean)
NetInterface:InitializeServer(Int32, Int32, Boolean)
uLinkNetwork:Start()


file 12_1_2017_log.log
Code: [Select]
[Log]:12/01/2017 20:08:56
Current server version:262

[Log]:12/01/2017 20:08:57
Server initialized on port:9900

file 12_1_2017_warning.log
Code: [Select]
[Warning]:12/01/2017 20:08:56
Socket ReceiveBuffer is actually set to 425984 and not the desired 134217728

[Warning]:12/01/2017 20:08:56
Socket SendBuffer is actually set to 425984 and not the desired 134217728

Server console log:
Code: [Select]
Found path: /XXX/XXX/PE/HeadlessServer/PE_Server.x86_64
Mono path[0] = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Managed'
Mono path[1] = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Mono'
Mono config path = '/XXX/XXX/PE/HeadlessServer/PE_Server_Data/Mono/etc'


Dorist1 did you also get the same error in the exception log? "FormatException: Unknown char: ."
This line of log appears at the first start of the server, (so I do not think this is a broken backup as you thought in your first response), but I think if you do not have this error in your logs the problem starts there....

And for your test on Debian (Jessie?) you used the HeadlessServer/PE_Server.x86_64 right?

Are there any command line arguments that I can add to the server's start command to have more logs?
« Last Edit: January 12, 2017, 07:33:50 PM by Narkos »
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #8 on: January 13, 2017, 06:04:34 AM »

First, delete the whole ServerData folder, then start the server with commond:  ./PE_Server.x86_64, rather than sh PEStart.sh

Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #9 on: January 13, 2017, 02:50:57 PM »

Hello Dorist1,

Thank you for your answer.

I deleted the ServerData folder.
I started the PE server with this command line: ./PE_Server.x86_64

I get the same error on server connection.
And I get the same exceptions in the logs as in my previous messages.
« Last Edit: January 13, 2017, 02:56:19 PM by Narkos »
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #10 on: January 13, 2017, 03:06:47 PM »

I googled a bit about the format exception error in the parse method as seen in the exception logs.

I found this post with the same character exception with the "." (also using unity):
https://forum.unity3d.com/threads/float-parse-string-s-crash.343256/

Maybe there is no link with my problem, but in this post an answer talk about french language, and i'm also using french language in steam, so maybe the format exception is related to localization/translation?
« Last Edit: January 13, 2017, 03:53:07 PM by Narkos »
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #11 on: January 14, 2017, 06:44:32 PM »

Today I installed Ubuntu 16.04 Lts 64 on a new dedicated server to make a test, I also installed Planet explorers server and it works just fine.

The headless server on Debian (Jessie 64) do not work...
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #12 on: January 16, 2017, 03:03:21 AM »

We'd check if this problem is a language related one. Could you share your language library here with Dropbpx for testing?
Logged

Narkos

  • Enlistee
  • *
  • Karma: 0
  • Posts: 11
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #13 on: January 16, 2017, 05:00:30 PM »

I don't understand what language file do you ask...

The only PE server language file I found is i18n.db that has only translations from english to chinese...

If you ask about Debian language files... they should also be present on the debian server you tested on right?

What file do you need?
« Last Edit: January 16, 2017, 05:17:17 PM by Narkos »
Logged

Dorist1

  • Administrator
  • Planetary Hero
  • *****
  • Karma: 44
  • Posts: 2269
    • View Profile
Re: Dedicated server "Severe server error" (Debian Jessie 64)[marked]
« Reply #14 on: January 17, 2017, 03:08:07 AM »

I meant the french language. I thought you have that translation script.
Logged
Pages: [1] 2