Pathea Games Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Planet Explorers Released!

Author Topic: 3.5 crashes on start up every time.  (Read 119 times)

Gyson

  • Enlistee
  • *
  • Karma: 0
  • Posts: 4
    • View Profile
3.5 crashes on start up every time.
« on: December 03, 2017, 08:08:26 PM »

Ever since the 3.5 update, whenever I launch the game it crashes before reaching the main menu, ever single time. The error it shows can be seen here:

https://c1.staticflickr.com/5/4520/38813489821_e4d8efd964_o.jpg

Output_log.txt also attached.

I do not have any peripherals or USB devices plugged in other than a Logitech mouse and Microsoft keyboard.

I did not have this problem in the free Steam demo. I did not have an opportunity to test 3.0.
« Last Edit: December 03, 2017, 08:14:27 PM by Gyson »
Logged

zly1991

  • Enlistee
  • *
  • Karma: 0
  • Posts: 9
    • View Profile
Re: 3.5 crashes on start up every time.
« Reply #1 on: December 04, 2017, 03:25:32 AM »

some programmable mice or some half-keyboards are also incompatible
Logged

Gyson

  • Enlistee
  • *
  • Karma: 0
  • Posts: 4
    • View Profile
Re: 3.5 crashes on start up every time.
« Reply #2 on: December 04, 2017, 01:50:42 PM »

Well, this is a Logitech G600, which is not exactly a new (or uncommon) mouse.  I don't have an alternate mouse to test it with.  And the Microsoft Keyboard is just an older Natural Keyboard Pro - nothing fancy going on there.

The game seemed fine with both in earlier versions - the only crash I ever encountered in the previous iterations was the known issue of dueling a Civil Corps member to gain access to the ruins (which resulted in a crash).  However, as I said that was a known bug.  Beyond that the game had been pretty stable for me.  Now I can't even get it to launch.
Logged

zly1991

  • Enlistee
  • *
  • Karma: 0
  • Posts: 9
    • View Profile
Re: 3.5 crashes on start up every time.
« Reply #3 on: December 07, 2017, 06:59:26 AM »

i tested this, i couldnt launch game if the mouse with multiple buttons plugged in.
Logged

Gyson

  • Enlistee
  • *
  • Karma: 0
  • Posts: 4
    • View Profile
Re: 3.5 crashes on start up every time.
« Reply #4 on: December 08, 2017, 01:44:25 AM »

After some testing, I found out that it was not my mouse or keyboard the game was taking issue with, but my installation of VJoy.  Once I uninstalled VJoy, the game loaded without issue.

Now, I've had the same version of VJoy installed on my system for a while now, without issue, and even the free demo version of My Time at Portia on Steam didn't seem to have a problem with it.  But the 3.5+ version of this game will not make it to the main menu without crashing as long as I have VJoy installed.

I do need to use VJoy for other games, and it is my hope that the Portia developers have an interest in resolving the current incompatibility issue, rather than just assuming everyone will be willing to keep VJoy off of their systems.
« Last Edit: December 08, 2017, 01:47:08 AM by Gyson »
Logged